Jump to content
Sign in to follow this  
Pikachu

PC Tech Is my power supply going bad?

Recommended Posts

I was playing a game and it randomly froze and caused it to go to the error reporting screen. I rebooted and my peripherals were not getting power after getting to the Windows log in screen. I rebooted a third time and everything came back fine. I tried playing the same game again and it froze and peripherals lost power but the PC remained on. 

 

I googled around and the symptoms seem to match, but I am not entirely sure. Any tests I can run before I get a new PSU?

Share this post


Link to post
Share on other sites
22 hours ago, Pikachu said:

I was playing a game and it randomly froze and caused it to go to the error reporting screen. I rebooted and my peripherals were not getting power after getting to the Windows log in screen. I rebooted a third time and everything came back fine. I tried playing the same game again and it froze and peripherals lost power but the PC remained on. 

 

I googled around and the symptoms seem to match, but I am not entirely sure. Any tests I can run before I get a new PSU?

Did you move your KB/M to different USB slots to see if the issues continues?

Did you try different KB/M?

If your MOBO has a video out try disconnecting the graphics card and see if the problem persists

 

Share this post


Link to post
Share on other sites

Ok, I replaced the PSU, and I cleaned all the fans including the front ones. CPU and GPU fans are working. Heatsink has minimal dust. Core Temp shows a min temp of 39 and max of 60 while not playing games and max of 85 when playing. Played two matches in Overwatch and a bit of Tomb Raider without issue. Hopefully, that fixed the issue. I'll update if anything changes.

Share this post


Link to post
Share on other sites
1 hour ago, Pikachu said:

Ok, I replaced the PSU, and I cleaned all the fans including the front ones. CPU and GPU fans are working. Heatsink has minimal dust. Core Temp shows a min temp of 39 and max of 60 while not playing games and max of 85 when playing. Played two matches in Overwatch and a bit of Tomb Raider without issue. Hopefully, that fixed the issue. I'll update if anything changes.

 

What brand PSU did you have? What did you buy?

Share this post


Link to post
Share on other sites
13 minutes ago, Spork3245 said:

 

What brand PSU did you have? What did you buy?

I had an Antec which was nearly 7 years old. I got an EVGA PSU this time.

Share this post


Link to post
Share on other sites
3 hours ago, Pikachu said:

I had an Antec which was nearly 7 years old. I got an EVGA PSU this time.

Lol.  If you had started this thread with "I have a 7-year old PSU" -- then nobody would have suggested other fixes.

Share this post


Link to post
Share on other sites
26 minutes ago, mikechorney said:

Lol.  If you had started this thread with "I have a 7-year old PSU" -- then nobody would have suggested other fixes.

 

Good news: EVGA PSUs have a 10 year warranty! :o 

Share this post


Link to post
Share on other sites
18 minutes ago, Spork3245 said:

 

Good news: EVGA PSUs have a 10 year warranty! :o 

Some of them do....

 

i never  have my receipts for that long though 

Share this post


Link to post
Share on other sites
38 minutes ago, mikechorney said:

Some of them do....

 

i never  have my receipts for that long though 

 

You register it online and upload the receipt immediately to your account...

Share this post


Link to post
Share on other sites
44 minutes ago, Spork3245 said:

 

You register it online and upload the receipt immediately to your account...

:)

I should probably register stuff at some point.

Share this post


Link to post
Share on other sites
1 minute ago, mikechorney said:

:)

I should probably register stuff at some point.

 

It’s usually a good idea :p 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...