Sign in to follow this  
Followers 0

Vita Touch Screen not Working

10 posts in this topic

Posted · Report post

Played it 5-6 hours earlier and put it on standby, and now I can't get it off the swipe screen. Also can't press the "Power off" button.

Anyone have this happen? I figure I'll "wait and see," but it is pretty odd.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hold the power button till it restarts.

This usually fixes most problems with any electronic gadget. :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

I just had that happen to me yesterday. The vita had been in standby since the night before and I had to force shut down, but it worked fine after that.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Fortunately I came back to it and it was working again; I had a pretty long Sunflowers turn going--- which I died 2 minutes afterwards :P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Did you plug it in to charge soon before the issue began?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Did you plug it in to charge soon before the issue began?

It had been on the charger for a while; I had been playing, then put it to standby as always. 5-6 hours later it was stuck. First time it ever happened for me, and I did not like it one bit :nottalking:

0

Share this post


Link to post
Share on other sites

Posted · Report post

It had been on the charger for a while; I had been playing, then put it to standby as always. 5-6 hours later it was stuck. First time it ever happened for me, and I did not like it one bit :nottalking:

It was charging while on standby? Most instances I've heard of the Vita's touch screen going bonkers started while plugged in.

0

Share this post


Link to post
Share on other sites

Posted · Report post

It happens to me from time to time. I never power the vita down, always standby. I think it just needs a reset every once in a while. Shitty bug though.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0